Skip to content
 

AntSnes 0.61

AntSnes is a Snes9x port to S60 3.x.
Bugs Fixed in 6.1 from 6.0

  • OpenGL ES Support

Whats new:

  • Battery saves
  • New fancy icon
  • savestate bug fixed. 0.5 users see known issues!
  • Modified key config. All 0.5 version users must update the key config after this Release.
    After settings the screen to the N-gage mode the user must set keys again, since the S60 keypad doesn’t know that feature. The update was made for E75 users, who might not have the d-pad mapped for arrow keys
  • Localization for: Danish, Hungarian, Indonesian, Brazilian Portuguese and Russian besides the English.
  • Don’t like the localization? No prob. You can just download the English only package too.

know issues:

  • Audio still sucks!
  • due to a bug in previous 0.5 version the save/load slot places have changed. Try to find you own correct save slot. Doesn’t affect to users who haven’t used the previous version..
  • There are still some issues in localization

Thanks for the localization goes to following persons:

  • Danish 07 by: Jens kikkenborg
  • Hungarian 17 by: Attila Molnรกr
  • Indonesian 59 by: Antok
  • Brazilian Portuguese 76 by: Rodrigo Carus
  • Russian 16 – Chepelev Anton
  • Polish 27 – Krzysztof Urbanowicz

Did you want to make translation for your own native language, but missed AntSnes release 0.6? Don’t worry, you’ll get a new chance later when I’m making a port for the S60 5th edition.

Installation:
Just download and install
Video settings:
Video Renderers: A restart is required after video renderer has been changed

  • DirectScreenAccess -Default, works in every phone
  • OpenGL ES 1.1 – Renders snes frames in full screen. Requiresย  OpenGL ES 1.1, so it doesn’t work in all devices.

Screen Orientatuions: A restart is required after orientation has been changed

  • portrait – Default
  • Landscape – Normal landscape
  • N-Gage – landscape, but image is upside down. It’s meant for phones with “n-gage mode” like N95 and N96. The N96 can use the multimediakeys by default, but N95 users must use Magic keys to map keys 1-4 to multimediakeys.

Frame skip:

  • Auto – continually adjust the frame skip speed to make your games play as smooth as possible
  • User define speed – some games might not run very well with Auto selection, since the frame rendering might take longer than a frame time with audio frame etc. Feel free to test different options, if you wish.

Show FPS:

  • Off – default
  • On – Show frames per second on upper left corner.

The Video settings modification takes effect, when AntSnes is started next time( a restart required).

N96 keymap

N96 keymap

Audio Settings:
The Audio isn’t probably working. If you get it working, please post you config, phone and the game ๐Ÿ™‚
Enable Audio: On/Off
Sample Rate: 8000Hz, 11025Hz, 16000Hz, 22050Hz and 44100Hz can be chosen
Stereo: On/Off
Volume: Adjust volume
Enable SpeedHack: On/Off. The SpeedHack makes audio render a bit faster, but it might cause some errors with some roms.
Key config
Start key config to configure keys. The multimediakeys are not supported in the key config, but you can use any normal keys in here.
Download:
AntSnes English only: AntSnes_v061_en.sis
AntSnes with localization: AntSnes_v061.sis
[ad]
sources: AntSnes_v061.zip

17 Comments

  1. ReS says:

    OpenGL ES works now, only problem is i cant get fps counter on it, and the danish translation cant show รฆรธรฅ.
    Sound is still causing the program to crash, i think it is my N95 that is kinda fucked up, on N5800 the sound just inst there.
    portrait mode is now full screen, like streched all the down, in the last version it was side to side not streched down.
    and in N-Gage mode the fps counter is upside down, and the game screen is upside down too ๐Ÿ™‚
    Landscape mode works fine, fps counters hows up nice, and the screen is clean execpt for some green stuff at the buttom of the screen.
    else i must say its running alittle better now on zelda then the last versions ๐Ÿ™‚

  2. Mirek says:

    I have big problems on my new Nokia E51 with newer versions of AntSnes… “DirectScreenAccess” results in black screen in 0.61. The same happened with 0.5. And afterwards I cannot even open the dialog to load ROM files (it looks like the program freezes when attempting to do that). It recovers only after reinstalling another version of AntSnes… But I am able to reproduce it in this way reliably again…
    The best version for me is 0.4. It seems to work ok on Nokia E51 both with “DirectScreenAccess” and “OpenGL”. The above mentioned problem does not appear. But the later versions are all screwed up.
    Here it is written than “DirectScreenAccess” should work everywhere – am I the only one with this problem?
    What has changed between 0.4 and 0.5 as far as “DirectScreenAccess” is concerned?
    My phone is a new one from Vodafone, less than a week old and otherwise I have no problems with it.
    Mirek

    • Summeli says:

      It should work with all 3.x phones. For me it works with N73, N95 and N96, so I can’t test with your phone. Did you try to uninstall the AntSnes and then install 0.61 version again?

      • Mirek says:

        Ok, maybe a problem elsewhere, but definitely buggy…
        A moment ago I did this:
        1. Uninstalling AntSnes 0.4
        2. Installing AntSnes 0.61
        3. Starting game (file dialog was ok, the game started)
        4. Redefining keys (Key Config) – I used up, down, left, right, 1, 2, 3, 4 etc.
        5. Exiting the AntSnes
        6. Starting AntSnes
        7. Choosing “Load ROM” -> black screen (though not frozen, I could get menu)
        8. Choosing OpenGL in settings
        9. Choosing “Load ROM” – white screen, menu is visible – but no open file dialog (otherwise as in 7)

        Now it is in the state from which I do not know how to recover (apart from reinstalling a different version (reinstalling 0.61 does not help – there are still weird problems – menu is visible, but “load rom” does not work).
        Mirek

        • Summeli says:

          I really can’t reproduce this. Can you try to use the “set default settings” option one after install?

          • Mirek says:

            I think I narrowed it down…
            It happens when I run a game in AntSnes (ok) and then exit (normally Exit from AntSNES menu). After the next start of AntSnes these problems will happen.
            Loading “Default Settings” helps to recover.
            So it looks like the AntSnes screws up settings somehow… Is there anything automativally saved when game is played and AntSnes is ended?
            Sorry for the misleading original report…
            Mirek

          • Summeli says:

            Sorry, still can’t reproduce. The default settings + restart should allways work. I have no idea why it isn’t working for you.

          • Summeli says:

            I can’t reproduce, but I can ques the cause now. There is a small difference how the last rom name is saved. It works just fine with all my phones, but it might be that Nokia has made a bug in their platform ๐Ÿ™‚ Does this happen to you each time after loading a game?

          • Mirek says:

            I tried several time – running the game, exiting, restarting AntSnes, attempting to load (no open file dialog ๐Ÿ™‚ ). Several games.
            I wonder – maybe it has something to do with the feature added in 0.5:
            – remembers last rom directory
            It looks quite suspiciously.
            I am 90% sure that AntSnes 0.4 was fine when I tested it yesterday…
            Mirek

          • Summeli says:

            I agree. There is no other changes between 0.4 and 0.5 that could have caused this. I can’t reproduce, but there were other complaints about settings in 0.5 too. Can you make the same test again, if I’ll release 0.62 version today with (hopefully) working settings?

          • Mirek says:

            Maybe make the “remember last rom” optional…
            Ok. I will test in the evening (unfortunately it is the phone of my wife, I do not have it now and I will come at home only around 6pm).
            I will let you know.
            Thanks for the great program and support. Symbian scene is quite dead so it is good to see people like you making great programs.
            Mirek

  3. LiL_Stenly says:

    I can make Bulgarian translation… however I don’t know where are the gui strings to make translation, can you give me a little guide about it?

Leave a Reply

(required)